Dateien (Objekte) werden nicht angezeigt.

Schnelle Hilfe bei Problemen mit 111MB Webhosting.
Forumsregeln
Bitte lese vor dem Erstellen einer Anfrage unsere Hilfe - eventuell findest du dort noch schneller eine Lösung!
Antworten
famoir1

Dateien (Objekte) werden nicht angezeigt.

Beitrag von famoir1 »

Hallo zusammen,

habe ein einfaches Problem. Und hoffe auf Hilfe.

Und zwar werden in der von mir hochgeladenen Homepage nicht alle Bilder angezeigt.

1. Ich habe alle hochgeladen & auch die HTML-href Verweise stimmen 100% überein.
2. Ein grosser Teil der Bilde funktioniert, jedoch nicht alle ca. 5 von 20
3. ich habe versucht die betroffenden Bilder zu löschen und erneut hochzuladen (vermutete einen Fehler beim übertragen), hat aber leider das Problem nicht gelöst.

Gibt es eine gewisse Bearbeitungszeit oder ein internes Problem.
Würde mich über eine kurze Info freuen.

Liebe Grüße
Famoir

Benutzeravatar
patrick
Administrator
Beiträge: 451
Registriert: 01.07.2007, 17:55
Wohnort: Stuttgart
Kontaktdaten:

Re: Dateien (Objekte) werden nicht angezeigt.

Beitrag von patrick »

Hallo,

nein, das ist kein internes Problem. Bilder die nicht angezeigt werden, sind schlichtweg nicht vorhanden.
Und das hat sich beim überfliegen deiner Seite auch bestätigt: hier bspw. (Menüpunkt "Zaunsysteme")
hier fehlt bspw. die Datei
bilder/zaun/schiebtor2.jpg
bilder/zaun/flgeltor2.jpg
bilder/zaun/spitzbogen2.jpg
Wenn das Bild defekt wäre, würde es nicht angezeigt werden / ein Fehler auftreten. Hier tritt aber ein 404-Fehler auf, was eindeutig heißt, dass die Datei nicht vorhanden ist.

Hinweis: es gibt bei Dateinamen unterschiede zwischen GROß und kleinschreibung ! Wenn die Datei bspw. "ZaUn_2.jpG" heißt, muss diese auch direkt auf diesen Namen verlinken - ein "zaun_2.jpg" reicht hier nicht aus. (und das scheint bei dir der Fall zu sein, im WebFTP sind die Dateien mit .JPG, verlinkt werden sie jedoch auf .jpg)

famoir1

Re: Dateien (Objekte) werden nicht angezeigt.

Beitrag von famoir1 »

und da steckt mein Problem =)

Denn die Dateien sind auf dem ftp, vorhanden...

Ich werde , den Code noch einmal stück für stück durchgehen (bzw. den verweis).
Alternativ probiere ich einfach die Dateien inkl. verweise umzubenennen.
Denn bei den anderen Bildern funktioniert dies ja auch einwandfrei.
nunja aber vorerst ein Danke , das du mal drüber geschaut hast.

:?

Benutzeravatar
patrick
Administrator
Beiträge: 451
Registriert: 01.07.2007, 17:55
Wohnort: Stuttgart
Kontaktdaten:

Re: Dateien (Objekte) werden nicht angezeigt.

Beitrag von patrick »

famoir1 hat geschrieben:und da steckt mein Problem =)

Denn die Dateien sind auf dem ftp, vorhanden...
Sind sie nicht. Die Datei, auf die auf der Seite verlinkt wird, lautet
<td><p><span class="rahmen"> <img src="bilder/zaun/spitz2.jpg" alt=""></td>
Die Datei, die im WebFTP verfügbar ist, heißt jedoch
spitz2.JPG
Und bei den anderen, fehlerhaften Bildern, wird vermutlich dasselbe Problem bestehen.

Konkretes Bsp.: http://famoir1.111mb.de/bilder/zaun/spitz2.jpg (Verlinkung auf der Seite, ergibt Datei nicht gefunden)
die selbe Datei, aber mit .JPG am Ende: http://famoir1.111mb.de/bilder/zaun/spitz2.JPG funktioniert jedoch, und darin liegt dein Problem :P

Das Problem, das bei dir besteht, ist dass Dateien bspw. mit *.jpg verlinkt werden, in wirklichkeit aber *.JPG heißen.

Bei anderen Hostern mag dies egal sein, ob die Datei nun xyz.jpg oder xyz.JPG heißt, aber hier ist das bewusst deaktiviert.

Antworten